Page 1 of 1

Hi Point C9 feed problems

PostPosted: Mon Mar 20, 2017 12:13 am
by FordMan59
Guys I've got C9 that's giving me feeding issues. The gun is fairly low round count but I shouldn't be getting several misfeeds per mag. I was already in a bad mood this afternoon when I took it out to shoot a few rounds. First shot shot fine, but the bullet nosedived and jammed her up. Being in a bad mood I cleared the jam and gave up on it. I've had these problems out of the C9 previously, I wasn't going to fight with it today being in a poor mood, I might have ended up shooting myself. I've got 2 8 round and 1 10 round factory mags and have the same problem with them all. The mags are kept loaded between shootings. Give me some suggestions of what needs to be done.

Re: Hi Point C9 feed problems

PostPosted: Mon Mar 20, 2017 5:56 pm
by Stik
Sometimes the feed lips of the C9 mags need to be adjusted. If you go to the Hi-Point forum and do a search you should be able to find a thread on it. Be careful when doing this though, and it's at your own risk. I also find that a gentle tap the base of the magazine on a hard surface helps. Some HPs need to have the feed ramp polished, but that doesn't sound like your problem here.

Note: Photo borrowed from the Hi-Point forums.

Image

Re: Hi Point C9 feed problems

PostPosted: Mon Mar 20, 2017 8:18 pm
by adam01364
Does the problem occur with all brands of ammo? I had a bad batch of WWB in 9mm and it gave me fits.

Re: Hi Point C9 feed problems

PostPosted: Mon Mar 20, 2017 9:02 pm
by Flowmaster
I've had weird feeding issues using Monarch brand steel cased 9mm. I think its rebranded Tula or Barnaul or Vympel or something. It definitely could be the ammo.

Re: Hi Point C9 feed problems

PostPosted: Tue Mar 21, 2017 2:58 am
by FordMan59
adam01364 wrote:Does the problem occur with all brands of ammo? I had a bad batch of WWB in 9mm and it gave me fits.


Maybe that's the problem. WWB is what I've been using and was using Sunday. I've got some Freedom Munitions reloads and some Remington UMC, maybe I should try another brand for awhile and see if it helps. Last time I shot it I ran Winchester SXZ (Bass Pro Shop) hollow points and don't recall any problems. I really hadn't given the ammo much thought since most of my guns run good on anything I feed them. I do recall having some problems a few years ago with a couple of my .22's not wanting to function 100% on Winchester bulk ammo. Maybe I'll try a different brand ammo and if that doesn't fix it I'll try adjusting the feed lips, if that doesn't work I can try polishing the feed ramp. Worst come to worst I'll send it back to Hi Point and let them deal with it.Thanks for the tips and replies.